Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: VMWare :: b06-3730.htm

VMware possible incorrect permissions on SSL key files



VMSA-2006-0003 VMware possible incorrect permissions on SSL key files
VMSA-2006-0003 VMware possible incorrect permissions on SSL key files



This is a multi-part message in MIME format.
--------------080508030205090404080209
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


- -------------------------------------------------------------------
                   VMware Security Advisory

Advisory ID:       VMSA-2006-0003
Synopsis:          VMware possible incorrect permissions on SSL key files
			VMware Player for Linux
			VMware Workstation for Linux
			VMware Server for Linux
			VMware ESX Server 2.x
			VMware Infrastructure 3

			NOT VULNERABLE: VMware Player for Windows
			NOT VULNERABLE: VMware Workstation for Windows
			NOT VULNERABLE: VMware Server for Windows
VMTN Knowledge Base URL: http://kb.vmware.com/kb/2467205 
Issue date:        2006-07-18
Updated on:        2006-07-18
CVE Name:          CVE-2006-3589
- -------------------------------------------------------------------

1. Summary:

The configuration program, vmware=ADconfig.pl, may not correctly set
file permissions on the generated SSL Key files which is used for 
encrypting traffic for remote administrative connections.

VMware has given this issue a Priority 3 severity rating.

2. Relevant release:

VMware Player for Linux
VMware Workstation for Linux
VMware Server for Linux
VMware Infrastructure 3

NOT VULNERABLE: VMware Player for Windows
NOT VULNERABLE: VMware Workstation for Windows
NOT VULNERABLE: VMware Server for Windows

3. Problem description:

The script vmware-config.pl sets permissions on the key and
certificate files to safe values. However this script does not use
the safe_chmod() subroutine which reports errors on failure.
Instead, the native Perl chmod() function is used, without any
return code checking.

Because the safe_chmod() subroutine is not used and no return code
checks are performed, the user is not alerted if the chmod() fails.
Depending on the umask being used at the time this could leave the
key file readable to any local user on the system.

4. Solution:

VMware is working on a fix, and there is a workaround.  Manually
change the permissions on the key and certificate to its intended
values. The following commands would be appropriate on a default
installation:

# chmod 400 /etc/vmware/ssl/rui.key
# chmod 444 /etc/vmware/ssl/rui.crt

The Common Vulnerabilities and Exposures (CVE) project has assigned the
name CVE-2006-3589 to this issue.

5. References:

http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3589 

6. Acknowledgments

VMware would like to thank Nick Breese and security-assessment.com.

7. Contact:

http://www.vmware.com/security 

Copyright 2006 VMware Inc. All rights reserved.


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFErFC+LsZLrftG15MRAmm8AKCj6Li52ztaGuPO78GyqXWaQSLTRgCaAnj3
3Wg2D5U/S9SkrzDSTR9OsWI=wppd
-----END PGP SIGNATURE-----


--------------080508030205090404080209
Content-Type: text/plain;
 name="VMSA-2006-0003.txt.asc"
Content-Disposition: inline;
 filename="VMSA-2006-0003.txt.asc"
Content-Transfer-Encoding: quoted-printable

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


- -------------------------------------------------------------------
                   VMware Security Advisory

Advisory ID:       VMSA-2006-0003
Synopsis:          VMware possible incorrect permissions on SSL key files
			VMware Player for Linux
			VMware Workstation for Linux
			VMware Server for Linux
			VMware ESX Server 2.x
			VMware Infrastructure 3

			NOT VULNERABLE: VMware Player for Windows
			NOT VULNERABLE: VMware Workstation for Windows
			NOT VULNERABLE: VMware Server for Windows
VMTN Knowledge Base URL: http://kb.vmware.com/kb/2467205 
Issue date:        2006-07-18
Updated on:        2006-07-18
CVE Name:          CVE-2006-3589
- -------------------------------------------------------------------

1. Summary:

The=A0configuration=A0program,=A0vmware=ADconfig.pl,=A0may=A0not=A0correctly=A0set 
file permissions on=A0the=A0generated=A0SSL Key=A0files=A0which=A0is=A0used=A0for=A0
encrypting=A0traffic=A0for=A0remote=A0administrative=A0connections.

VMware has given this issue a Priority 3 severity rating.

2. Relevant release:

VMware Player for Linux
VMware Workstation for Linux
VMware Server for Linux
VMware Infrastructure 3

NOT VULNERABLE: VMware Player for Windows
NOT VULNERABLE: VMware Workstation for Windows
NOT VULNERABLE: VMware Server for Windows

3. Problem description:

The script vmware-config.pl sets permissions on the key and 
certificate files to safe values. However this script does not use 
the safe_chmod() subroutine which reports errors on failure. 
Instead, the native Perl chmod() function is used, without any 
return code checking.
 
Because the safe_chmod() subroutine is not used and no return code 
checks are performed, the user is not alerted if the chmod() fails. 
Depending on the umask being used at the time this could leave the 
key file readable to any local user on the system. 

4. Solution:

VMware is working on a fix, and there is a workaround.  Manually 
change the permissions on the key and certificate to its intended 
values. The following commands would be appropriate on a default 
installation:

# chmod 400 /etc/vmware/ssl/rui.key
# chmod 444 /etc/vmware/ssl/rui.crt 

The Common Vulnerabilities and Exposures (CVE) project has assigned the
name CVE-2006-3589 to this issue.  

5. References:

http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3589 

6. Acknowledgments

VMware would like to thank Nick Breese and security-assessment.com.

7. Contact:

http://www.vmware.com/security 

Copyright 2006 VMware Inc. All rights reserved.


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFErFC+LsZLrftG15MRAmm8AKCj6Li52ztaGuPO78GyqXWaQSLTRgCaAnj3
3Wg2D5U/S9SkrzDSTR9OsWI=wppd
-----END PGP SIGNATURE-----

--------------080508030205090404080209--


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH