Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Linux :: Trustix :: c07-1462.htm

Trustix Secure Linux - multiple vulns



TSLSA-2006-0074 - multi
TSLSA-2006-0074 - multi



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Trustix Secure Linux Security Advisory #2006-0074

Package names:	   kernel, proftpd
Summary:           Multiple vulnerabilities
Date:              2006-12-22
Affected versions: Trustix Secure Linux 2.2
                   Trustix Secure Linux 3.0
                   Trustix Operating System - Enterprise Server 2

- --------------------------------------------------------------------------
Package description:
  kernel
  The kernel package contains the Linux kernel (vmlinuz), the core of
  your Trustix Secure Linux operating system. The kernel handles the
  basic functions of the operating system: memory allocation, process
  allocation, device input and output, etc.

  proftpd
  ProFTPd is an enhanced FTP server with a focus toward simplicity,
  security, and ease of configuration. It features a very Apache-like
  configuration syntax, and a highly customizable server infrastructure,
  including support for multiple 'virtual' FTP servers, anonymous FTP,
  and permission-based directory visibility.

Problem description:
  kernel < TSL 3.0 >
  - New upstream.
  - SECURITY FIX: A vulnerability has been identified which could be
    exploited by malicious users to bypass security restrictions.
    This issue is due to an error in the "do_coredump()" [fs/exec.c]
    function where the "flag" variable is set but never used, which
    could be exploited by attackers to manipulate certain files.

    The Common Vulnerabilities and Exposures project (cve.mitre.org)
    has assigned the names CVE-2006-6304 to this issue. 

  proftpd < TSL 3.0 > < TSL 2.2 > < TSEL 2 >
  - SECURITY Fix: Alfredo Ortega has reported a vulnerability in the
    mod_ctrls module for ProFTPD, caused due to a boundary error within
    the "pr_ctrls_recv_request()" function in src/ctrls.c. This can be
    exploited to cause a buffer overflow by sending specially crafted
    control messages to the module.

    The Common Vulnerabilities and Exposures project (cve.mitre.org)
    has assigned the name CVE-2006-6563 to this issue.

Action:
  We recommend that all systems with this package installed be upgraded.
  Please note that if you do not need the functionality provided by this
  package, you may want to remove it from your system.


Location:
  All Trustix Secure Linux updates are available from
 
 


About Trustix Secure Linux:
  Trustix Secure Linux is a small Linux distribution for servers. With focus
  on security and stability, the system is painlessly kept safe and up to
  date from day one using swup, the automated software updater.


Automatic updates:
  Users of the SWUP tool can enjoy having updates automatically
  installed using 'swup --upgrade'.


Questions?
  Check out our mailing lists:
 


Verification:
  This advisory along with all Trustix packages are signed with the
  TSL sign key.
  This key is available from:
 

  The advisory itself is available from the errata pages at
 and 
 
  or directly at
 


MD5sums of the packages:
- --------------------------------------------------------------------------
2c319a538cc26cf03b9a17fb3ff4df6d  3.0/rpms/kernel-2.6.19.1-1tr.i586.rpm
69707c93ea442c4e8ebf7aa1d4a7443b  3.0/rpms/kernel-doc-2.6.19.1-1tr.i586.rpm
7e00ee0e2327505952a3743cef79ebf9  3.0/rpms/kernel-headers-2.6.19.1-1tr.i586.rpm
9711f05efa9f71bf026d377359552424  3.0/rpms/kernel-smp-2.6.19.1-1tr.i586.rpm
99ab70808348eb25ea5ae1487bf1eaa2  3.0/rpms/kernel-smp-headers-2.6.19.1-1tr.i586.rpm
96853e3f3b66f8f07b0182c4223e9e37  3.0/rpms/kernel-source-2.6.19.1-1tr.i586.rpm
99d1599409ad3dc983f3fde2e60c8d79  3.0/rpms/kernel-utils-2.6.19.1-1tr.i586.rpm
300b6bddf5dc4aa0315b9ceb45426862  3.0/rpms/proftpd-1.3.0a-2tr.i586.rpm

c77328a47bcb91e46efc8ec803d4b038  2.2/rpms/proftpd-1.2.10-13tr.i586.rpm
- --------------------------------------------------------------------------


Trustix Security Team


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQFFi9iYi8CEzsK9IksRAiz/AJ4+hVL/kventhnTWjLBCTgbkicurACfcpkR
s6CFrC3ZzzKmFCgkC8r06mA=PHhm
-----END PGP SIGNATURE-----


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH