Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Linux :: Red Hat/Fedora :: m-059.txt

Red Hat groff Vulnerability (CIAC M-059)




             __________________________________________________________

                       The U.S. Department of Energy
                     Computer Incident Advisory Center
                           ___  __ __    _     ___
                          /       |     /_\   /
                          \___  __|__  /   \  \___
             __________________________________________________________

                             INFORMATION BULLETIN

                         Red Hat "groff" Vulnerability
                           [Red Hat RHSA-2002:004-11]

March 19, 2002 19:00 GMT                                          Number M-059
______________________________________________________________________________
PROBLEM:       The groff preprocessor contains an exploitable buffer overflow. 
PLATFORM:      Red Hat Linux 7.0 - alpha, i386 
               Red Hat Linux 7.1 - alpha, i386, ia64 
               Red Hat Linux 7.2 - i386, ia64, s390 
DAMAGE:        Remote exploitation may be possible if lpd is running and is 
               accessible remotely, and the attacker knows the name of the 
               printer and spoolfile. 
SOLUTION:      Update RPMS per vendor instructions. 
______________________________________________________________________________
VULNERABILITY  The risk is MEDIUM. The attacker would have to know the name of 
ASSESSMENT:    printer and spoolfile to exploit this vulnerability. 
______________________________________________________________________________
LINKS: 
 CIAC BULLETIN:      http://www.ciac.org/ciac/bulletins/m-059.shtml 
 ORIGINAL BULLETIN:  https://www.redhat.com/support/errata/RHSA-2002-004.html 
______________________________________________________________________________

[***** Start Red Hat RHSA-2002:004-11 *****]

-------------------------------------------------------------------------
 
Synopsis: New groff packages available to fix security problems  

-------------------------------------------------------------------------
  
Advisory ID: RHSA-2002:004-11  

-------------------------------------------------------------------------
  
Issue Date: 2002-01-07  

-------------------------------------------------------------------------
  
Updated On: 2002-03-13  

-------------------------------------------------------------------------
  
Product: Red Hat Linux  

-------------------------------------------------------------------------
  
Keywords: groff security  

-------------------------------------------------------------------------
  
Cross References:  

-------------------------------------------------------------------------
  
Obsoletes:  

-------------------------------------------------------------------------
  
1. Topic:

New groff packages have been made available that fix an overflow in 
groff. If the printing system running this is a security issue, it 
is recommended to update to the new, fixed packages. 

2. Problem description:

Groff is a document formatting system. The groff preprocessor contains 
an exploitable buffer overflow. If groff can be invoked within the 
LPRng printing system, an attacker can gain rights as the "lp" user.

Remote exploitation may be possible if lpd is running and is accessible
remotely, and the attacker knows the name of the printer and spoolfile.

The Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CAN-2002-0003 to this issue.

Thanks to zen-parse for bringing this bug to our attention. 

3. Bug IDs fixed: (see bugzilla for more information)

4. Relevant releases/architectures:

Red Hat Linux 7.0 - alpha, i386 
Red Hat Linux 7.1 - alpha, i386, ia64 
Red Hat Linux 7.2 - i386, ia64, s390

5. RPMs required:

Red Hat Linux 7.0:

SRPMS:
ftp://updates.redhat.com/7.0/en/os/SRPMS/groff-1.16-7.1.1.src.rpm

alpha:
ftp://updates.redhat.com/7.0/en/os/alpha/groff-1.16-7.1.1.alpha.rpm
ftp://updates.redhat.com/7.0/en/os/alpha/groff-perl-1.16-7.1.1.alpha.rpm
ftp://updates.redhat.com/7.0/en/os/alpha/groff-gxditview-1.16-7.1.1.alpha.rpm

i386:
ftp://updates.redhat.com/7.0/en/os/i386/groff-1.16-7.1.1.i386.rpm
ftp://updates.redhat.com/7.0/en/os/i386/groff-perl-1.16-7.1.1.i386.rpm
ftp://updates.redhat.com/7.0/en/os/i386/groff-gxditview-1.16-7.1.1.i386.rpm

Red Hat Linux 7.1:

SRPMS:
ftp://updates.redhat.com/7.1/en/os/SRPMS/groff-1.17.2-7.0.2.src.rpm

alpha:
ftp://updates.redhat.com/7.1/en/os/alpha/groff-1.17.2-7.0.2.alpha.rpm
ftp://updates.redhat.com/7.1/en/os/alpha/groff-perl-1.17.2-7.0.2.alpha.rpm
ftp://updates.redhat.com/7.1/en/os/alpha/groff-gxditview-1.17.2-7.0.2.alpha.rpm

i386:
ftp://updates.redhat.com/7.1/en/os/i386/groff-1.17.2-7.0.2.i386.rpm
ftp://updates.redhat.com/7.1/en/os/i386/groff-perl-1.17.2-7.0.2.i386.rpm
ftp://updates.redhat.com/7.1/en/os/i386/groff-gxditview-1.17.2-7.0.2.i386.rpm

ia64:
ftp://updates.redhat.com/7.1/en/os/ia64/groff-1.17.2-7.0.2.ia64.rpm
ftp://updates.redhat.com/7.1/en/os/ia64/groff-perl-1.17.2-7.0.2.ia64.rpm
ftp://updates.redhat.com/7.1/en/os/ia64/groff-gxditview-1.17.2-7.0.2.ia64.rpm

Red Hat Linux 7.2:

SRPMS:
ftp://updates.redhat.com/7.2/en/os/SRPMS/groff-1.17.2-7.0.2.src.rpm

i386:
ftp://updates.redhat.com/7.2/en/os/i386/groff-1.17.2-7.0.2.i386.rpm
ftp://updates.redhat.com/7.2/en/os/i386/groff-perl-1.17.2-7.0.2.i386.rpm
ftp://updates.redhat.com/7.2/en/os/i386/groff-gxditview-1.17.2-7.0.2.i386.rpm

ia64:
ftp://updates.redhat.com/7.2/en/os/ia64/groff-1.17.2-7.0.2.ia64.rpm
ftp://updates.redhat.com/7.2/en/os/ia64/groff-perl-1.17.2-7.0.2.ia64.rpm
ftp://updates.redhat.com/7.2/en/os/ia64/groff-gxditview-1.17.2-7.0.2.ia64.rpm

s390:
ftp://updates.redhat.com/7.2/en/os/s390/groff-1.17.2-7.0.2.s390.rpm
ftp://updates.redhat.com/7.2/en/os/s390/groff-perl-1.17.2-7.0.2.s390.rpm
ftp://updates.redhat.com/7.2/en/os/s390/groff-gxditview-1.17.2-7.0.2.s390.rpm

6. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade. Only 
those RPMs which are currently installed will be updated. Those RPMs 
which are not installed but included in the list will not be updated. 
Note that you can also use wildcards (*.rpm) if your current directory 
*only* contains the desired RPMs.

Please note that this update is also available via Red Hat Network. 
Many people find this an easier way to apply updates. To use Red Hat 
Network, launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the 
appropriate RPMs being upgraded on your system. 

7. Verification:

MD5 sum                           Package Name
-------------------------------------------------------------------------
2d8f124e3501a67d3869b2adb0e4ae9b 7.0/en/os/SRPMS/groff-1.16-7.1.1.src.rpm
99047829eb9ebd1d4db859f3b64b8a76 7.0/en/os/alpha/groff-1.16-7.1.1.alpha.rpm
3d4a15c5644c1bd2c24dae31f1095f4d 7.0/en/os/alpha/groff-gxditview-1.16-7.1.1.alpha.rpm
10e4f6583732fbf51bc23ab186c7b7bb 7.0/en/os/alpha/groff-perl-1.16-7.1.1.alpha.rpm
75beca33b7eeb77603c86e6219e0d26e 7.0/en/os/i386/groff-1.16-7.1.1.i386.rpm
93740b2ae27732d73e6e81d369293a0b 7.0/en/os/i386/groff-gxditview-1.16-7.1.1.i386.rpm
2b36d02d479bed1ab7d58dd692dc0a51 7.0/en/os/i386/groff-perl-1.16-7.1.1.i386.rpm
1d4e9b5068fcf178ddacf032c0db523d 7.1/en/os/SRPMS/groff-1.17.2-7.0.2.src.rpm
93cbf905335c1474ed9e632c0ec83738 7.1/en/os/alpha/groff-1.17.2-7.0.2.alpha.rpm
1d837785e127b4b9dc719b1f232816c6 7.1/en/os/alpha/groff-gxditview-1.17.2-7.0.2.alpha.rpm
465db9810916d6a346b75534c8e2cdc1 7.1/en/os/alpha/groff-perl-1.17.2-7.0.2.alpha.rpm
f3181dd6c32ffc9478721244b77c89af 7.1/en/os/i386/groff-1.17.2-7.0.2.i386.rpm
70ea6d89f289177fa4291e319347b3de 7.1/en/os/i386/groff-gxditview-1.17.2-7.0.2.i386.rpm
d6d520d69decc1c2243daa8179e956d7 7.1/en/os/i386/groff-perl-1.17.2-7.0.2.i386.rpm
4f08644532e54b8c3553b04148424e56 7.1/en/os/ia64/groff-1.17.2-7.0.2.ia64.rpm
c340eacc8bc4ad85894c200ef37cb715 7.1/en/os/ia64/groff-gxditview-1.17.2-7.0.2.ia64.rpm
82f6a180010606b6f0a7bd97aab39f42 7.1/en/os/ia64/groff-perl-1.17.2-7.0.2.ia64.rpm
1d4e9b5068fcf178ddacf032c0db523d 7.2/en/os/SRPMS/groff-1.17.2-7.0.2.src.rpm
f3181dd6c32ffc9478721244b77c89af 7.2/en/os/i386/groff-1.17.2-7.0.2.i386.rpm
70ea6d89f289177fa4291e319347b3de 7.2/en/os/i386/groff-gxditview-1.17.2-7.0.2.i386.rpm
d6d520d69decc1c2243daa8179e956d7 7.2/en/os/i386/groff-perl-1.17.2-7.0.2.i386.rpm
4f08644532e54b8c3553b04148424e56 7.2/en/os/ia64/groff-1.17.2-7.0.2.ia64.rpm
c340eacc8bc4ad85894c200ef37cb715 7.2/en/os/ia64/groff-gxditview-1.17.2-7.0.2.ia64.rpm
82f6a180010606b6f0a7bd97aab39f42 7.2/en/os/ia64/groff-perl-1.17.2-7.0.2.ia64.rpm
cfaac7783c958b90d50a8c4e7f2b5ad4 7.2/en/os/s390/groff-1.17.2-7.0.2.s390.rpm
488f1e2d9cf0c0c31ceb906243583654 7.2/en/os/s390/groff-gxditview-1.17.2-7.0.2.s390.rpm
06ebd59f8752df6ffc3ea8dd61443727 7.2/en/os/s390/groff-perl-1.17.2-7.0.2.s390.rpm

These packages are GPG signed by Red Hat, Inc. for security. Our key is 
available at: http://www.redhat.com/about/contact.html
You can verify each package with the following command: 
rpm --checksig filename

If you only wish to verify that each package has not been corrupted or 
tampered with,  examine only the md5sum with the following command: 
rpm --checksig --nogpg filename

Note that you need RPM >= 3.0 to check GnuPG keys. 

8. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2002-0003 

[***** End Red Hat RHSA-2002:004-11 *****]

_______________________________________________________________________________

CIAC wishes to acknowledge the contributions of Red Hat, Inc. for the 
information contained in this bulletin.
_______________________________________________________________________________


CIAC, the Computer Incident Advisory Center, is the computer
security incident response team for the U.S. Department of Energy
(DOE) and the emergency backup response team for the National
Institutes of Health (NIH). CIAC is located at the Lawrence Livermore
National Laboratory in Livermore, California. CIAC is also a founding
member of FIRST, the Forum of Incident Response and Security Teams, a
global organization established to foster cooperation and coordination
among computer security teams worldwide.

CIAC services are available to DOE, DOE contractors, and the NIH. CIAC
can be contacted at:
    Voice:    +1 925-422-8193 (7x24)
    FAX:      +1 925-423-8002
    STU-III:  +1 925-423-2604
    E-mail:   ciac@ciac.org

Previous CIAC notices, anti-virus software, and other information are
available from the CIAC Computer Security Archive.

   World Wide Web:      http://www.ciac.org/
   Anonymous FTP:       ftp.ciac.org

PLEASE NOTE: Many users outside of the DOE, ESnet, and NIH computing
communities receive CIAC bulletins.  If you are not part of these
communities, please contact your agency's response team to report
incidents. Your agency's team will coordinate with CIAC. The Forum of
Incident Response and Security Teams (FIRST) is a world-wide
organization. A list of FIRST member organizations and their
constituencies can be obtained via WWW at http://www.first.org/.

This document was prepared as an account of work sponsored by an
agency of the United States Government. Neither the United States
Government nor the University of California nor any of their
employees, makes any warranty, express or implied, or assumes any
legal liability or responsibility for the accuracy, completeness, or
usefulness of any information, apparatus, product, or process
disclosed, or represents that its use would not infringe privately
owned rights. Reference herein to any specific commercial products,
process, or service by trade name, trademark, manufacturer, or
otherwise, does not necessarily constitute or imply its endorsement,
recommendation or favoring by the United States Government or the
University of California. The views and opinions of authors expressed
herein do not necessarily state or reflect those of the United States
Government or the University of California, and shall not be used for
advertising or product endorsement purposes.

LAST 10 CIAC BULLETINS ISSUED (Previous bulletins available from CIAC)

M-049: Multiple PHP Vulnerabilities
M-050: Data Leak with Cisco Express Forwarding
M-051: Microsoft XMLHTTP Control Vulnerability
M-052: Microsoft Java Applet Can Redirect Browser Traffic
M-053: mod_ssl and Apache_SSL Modules Contain a Buffer Overflow
M-054: OpenSSH Contains Remote Exploitable Vulnerability
M-055: Microsoft Unchecked Buffer in Windows Shell
M-056: Red Hat "uuxqt" Vulnerability
M-057: Red Hat "at" Vulnerability
M-058: Apache Vulnerabilities on IRIX



TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH