Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Web :: PHP :: dsa-346.htm

phpsysinfo - directory traversal



Debian Security Advisory

DSA-346-1 phpsysinfo -- directory traversal

Date Reported:
08 Jul 2003
Affected Packages:
phpsysinfo
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CAN-2003-0536.
More information:

Albert Puigsech Galicia ripe@7a69ezine.org reported that phpsysinfo, a web-based program to display status information about the system, contains two vulnerabilities which could allow local files to be read, or arbitrary PHP code to be executed, under the privileges of the web server process (usually www-data). These vulnerabilities require access to a writable directory on the system in order to be exploited.

For the stable distribution (woody) this problem has been fixed in version 2.0-3woody1.

For the unstable distribution (sid) this problem will be fixed soon. See Debian bug #200543.

We recommend that you update your phpsysinfo package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Source:
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.0-3woody1.dsc
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.0-3woody1.diff.gz
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.0.orig.tar.gz
Architecture-independent component:
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.0-3woody1_all.deb

MD5 checksums of the listed files are available in the original advisory.



TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH