Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Web :: PHP :: b06-5470.htm

Integer overflow PHP:



PHP: Integer overflow
PHP: Integer overflow




--8GpibOaaTibBMecb
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200610-14
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/ 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: PHP: Integer overflow
      Date: October 30, 2006
      Bugs: #150261
        ID: 200610-14

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
PHP is vulnerable to an integer overflow potentially allowing the
remote execution of arbitrary code.

Background
=========
PHP is a widely-used general-purpose scripting language that is
especially suited for Web development and can be embedded into HTML.

Affected packages
================
    -------------------------------------------------------------------
     Package       /  Vulnerable  /                         Unaffected
    -------------------------------------------------------------------
  1  dev-lang/php     < 5.1.6-r6                          *>= 4.4.4-r6
                                                           >= 5.1.6-r6

Description
==========
A flaw in the PHP memory handling routines allows an unserialize() call
to be executed on non-allocated memory due to a previous integer
overflow.

Impact
=====
An attacker could execute arbitrary code with the rights of the web
server user or the user running a vulnerable PHP script.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All PHP 5.x users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-lang/php-5.1.6-r6"

All PHP 4.x users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-lang/php-4.4.4-r6"

References
=========
  [ 1 ] CVE-2006-4812
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-4812 

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200610-14.xml 

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org. 

License
======
Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5 

--8GpibOaaTibBMecb
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQFFRb9FIS4GNEW6wBQRAogBAJ9ZoOVv4NQx2BlhUzj1/+1G3Lr6pwCgsV4e
5MWGn2ZEHG7eXEvEzgKr120=Ubzf
-----END PGP SIGNATURE-----

--8GpibOaaTibBMecb--


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH