Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Oracle :: va2301.htm

Oracle Secure Backup Administration Server login.php Command Injection



iDefense Security Advisory 01.13.09: Oracle Secure Backup Administration Server login.php Command Injection Vulnerability
iDefense Security Advisory 01.13.09: Oracle Secure Backup Administration Server login.php Command Injection Vulnerability



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

iDefense Security Advisory 01.13.09
http://labs.idefense.com/intelligence/vulnerabilities/ 
Jan 13, 2009

I. BACKGROUND

Oracle Corp.'s Secure Backup is a tape backup management software, for
more information, please visit following website:
http://www.oracle.com/technology/products/secure-backup/index.html 

II. DESCRIPTION

Remote exploitation of two command injection vulnerabilities in the
authentication component of Oracle Corp.'s Secure Backup Administration
Server could allow an unauthenticated attacker to execute arbitrary
commands in the context of the running server.

In both cases, the vulnerabilities exist in PHP scripts that
authenticate a user attempting to use the service.

The first vulnerability is in "php/login.php". By making a login request
with a specially crafted cookie value, an attacker can execute arbitrary
code on the server.

The second vulnerability is in "php/common.php". This function is called
from the "login.php" page. A variable is used to specify a command to be
run. An attacker can supply any shell command for this variable and it
will be executed in the context of the web server process.

III. ANALYSIS

Exploitation allows an attacker to execute arbitrary shell commands in
the context of the web server process. Under Windows, the
Administration Server runs as SYSTEM, so the injected command will be
executed as SYSTEM. Under Linux it runs as an unprivileged user. No
authentication is required to exploit this vulnerability.

IV. DETECTION

Oracle Corp.'s Secure Backup version 10.2.0.2 for Linux, and Secure
Backup version 10.2.0.2 for Windows have been confirmed vulnerable.
Other versions and other platforms may also be affected.

V. WORKAROUND

Block access to the httpd interface of vulnerable servers.

VI. VENDOR RESPONSE

Oracle has released a patch which addresses this issue. For more
information, consult their advisory at the following URL.

http://www.oracle.com/technology/deploy/security/critical-patch-updates/cpujan2009.html 

VII. CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the
name CVE-2008-4006 to this issue. This is a candidate for inclusion in
the CVE list (http://cve.mitre.org/), which standardizes names for 
security problems.

VIII. DISCLOSURE TIMELINE

07/18/2008  Initial Vendor Notification
07/30/2008  Initial Vendor Reply
11/24/2008  Additional Vendor Feedback
01/13/2009  Coordinated Public Disclosure

IX. CREDIT

The discoverer of this vulnerability wishes to remain anonymous.

Get paid for vulnerability research
http://labs.idefense.com/methodology/vulnerability/vcp.php 

Free tools, research and upcoming events
http://labs.idefense.com/ 

X. LEGAL NOTICES

Copyright =A9 2009 iDefense, Inc.

Permission is granted for the redistribution of this alert
electronically. It may not be edited in any way without the express
written consent of iDefense. If you wish to reprint the whole or any
part of this alert in any other medium other than electronically,
please e-mail customerservice@idefense.com for permission. 

Disclaimer: The information in the advisory is believed to be accurate
at the time of publishing based on currently available information. Use
of the information constitutes acceptance for use in an AS IS condition.
 There are no warranties with regard to this information. Neither the
author nor the publisher accepts any liability for any direct,
indirect, or consequential loss or damage arising from use of, or
reliance on, this information.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org 

iD8DBQFJbR5Dbjs6HoxIfBkRAiqHAKDxgxrDdjVEkqbYmee6NGCIeoKOLACgtl24
BAfUScwWY6Jz5DBquOL3cbE=MpPP
-----END PGP SIGNATURE-----


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH