Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Linux :: Mandrake/Mandriva :: bu-1354.htm

imap vulns



imap
imap




-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

 Mandriva Linux Security Advisory                       MDVSA-2009:146-1
http://www.mandriva.com/security/ 
 _______________________________________________________________________

 Package : imap
 Date    : December 28, 2009
 Affected: 2008.0
 _______________________________________________________________________

 Problem Description:

 Security vulnerabilities has been identified and fixed in University
 of Washington IMAP Toolkit:
 
 Multiple stack-based buffer overflows in (1) University of Washington
 IMAP Toolkit 2002 through 2007c, (2) University of Washington Alpine
 2.00 and earlier, and (3) Panda IMAP allow (a) local users to gain
 privileges by specifying a long folder extension argument on the
 command line to the tmail or dmail program; and (b) remote attackers to
 execute arbitrary code by sending e-mail to a destination mailbox name
 composed of a username and '+' character followed by a long string,
 processed by the tmail or possibly dmail program (CVE-2008-5005).
 
 smtp.c in the c-client library in University of Washington IMAP Toolkit
 2007b allows remote SMTP servers to cause a denial of service (NULL
 pointer dereference and application crash) by responding to the QUIT
 command with a close of the TCP connection instead of the expected
 221 response code (CVE-2008-5006).
 
 Off-by-one error in the rfc822_output_char function in the RFC822BUFFER
 routines in the University of Washington (UW) c-client library, as
 used by the UW IMAP toolkit before imap-2007e and other applications,
 allows context-dependent attackers to cause a denial of service (crash)
 via an e-mail message that triggers a buffer overflow (CVE-2008-5514).
 
 The updated packages have been patched to prevent this. Note that the
 software was renamed to c-client starting from Mandriva Linux 2009.0
 and only provides the shared c-client library for the imap functions
 in PHP.

 Update:

 Packages for 2008.0 are provided for Corporate Desktop 2008.0
 customers.
 _______________________________________________________________________

 References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5005 
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5006 
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5514 
 _______________________________________________________________________

 Updated Packages:

 Mandriva Linux 2008.0:
 d8572c6bffe877abc1b19ccf251b7b67  2008.0/i586/imap-2006j-1.1mdv2008.0.i586.rpm
 4fdf949aa3a90b38153b4b09a51464e3  2008.0/i586/imap-devel-2006j-1.1mdv2008.0.i586.rpm
 f2d3ab0ba5b40ee0ee9d6acbb2c8ae9b  2008.0/i586/imap-utils-2006j-1.1mdv2008.0.i586.rpm
 df6476862c3ee9bbfb045f3afa2f80be  2008.0/i586/libc-client-php0-2006j-1.1mdv2008.0.i586.rpm
 94f81812a886325e028b3f4312cdf424  2008.0/i586/libc-client-php-devel-2006j-1.1mdv2008.0.i586.rpm 
 f2cc3ad757418c0e2b7e2f88d50761b6  2008.0/SRPMS/imap-2006j-1.1mdv2008.0.src.rpm

 Mandriva Linux 2008.0/X86_64:
 cf317e4b0e3098f5ef1ca66237360a84  2008.0/x86_64/imap-2006j-1.1mdv2008.0.x86_64.rpm
 443a626ac9a0db1e394eb3805dce4bf0  2008.0/x86_64/imap-devel-2006j-1.1mdv2008.0.x86_64.rpm
 c0963cfd6a9e886d6a0bb1391c63e4d6  2008.0/x86_64/imap-utils-2006j-1.1mdv2008.0.x86_64.rpm
 e63f1fa1bf88353332236373884c5330  2008.0/x86_64/lib64c-client-php0-2006j-1.1mdv2008.0.x86_64.rpm
 b864cb89b46f6e52a311e645b0e9e8d2  2008.0/x86_64/lib64c-client-php-devel-2006j-1.1mdv2008.0.x86_64.rpm 
 f2cc3ad757418c0e2b7e2f88d50761b6  2008.0/SRPMS/imap-2006j-1.1mdv2008.0.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories 

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team
  
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFLOPHOmqjQ0CJFipgRAiwWAKCpvjp1OUzTbZ7xPmCNoxX5eiioDwCffqYu
EwKEDYMKr6dcH1EcueeEAAI=3NaJ
-----END PGP SIGNATURE-----



TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH