Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Linux :: Mandrake/Mandriva :: bu-1134.htm

imagemagick vulns



imagemagick
imagemagick




-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

 Mandriva Linux Security Advisory                       MDVSA-2009:260-1
http://www.mandriva.com/security/ 
 _______________________________________________________________________

 Package : imagemagick
 Date    : December 5, 2009
 Affected: 2008.0
 _______________________________________________________________________

 Problem Description:

 A vulnerability has been found and corrected in ImageMagick,
 which could lead to integer overflow in the XMakeImage function in
 magick/xwindow.c, allowing remote attackers to cause a denial of
 service (crash) and possibly execute arbitrary code via a crafted
 TIFF file, which triggers a buffer overflow (CVE-2009-1882).
 
 This update fixes this vulnerability.

 Update:

 Packages for 2008.0 are being provided due to extended support for
 Corporate products.
 _______________________________________________________________________

 References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1882 
 _______________________________________________________________________

 Updated Packages:

 Mandriva Linux 2008.0:
 a518c3799c49cd407ca123eedd27631c  2008.0/i586/imagemagick-6.3.2.9-10.3mdv2008.0.i586.rpm
 72f4b32919fa8420cca925510fca21c8  2008.0/i586/imagemagick-desktop-6.3.2.9-10.3mdv2008.0.i586.rpm
 b0e5e58e38f7acd560aeb5bd53d065ed  2008.0/i586/imagemagick-doc-6.3.2.9-10.3mdv2008.0.i586.rpm
 ef3b5f6c1800fd10fbf7a437774d986c  2008.0/i586/libmagick10.7.0-6.3.2.9-10.3mdv2008.0.i586.rpm
 a3549fa4fa21089ff6b43e102932949e  2008.0/i586/libmagick10.7.0-devel-6.3.2.9-10.3mdv2008.0.i586.rpm
 5dde39fb31d70d8b20ce9b17e4baf457  2008.0/i586/perl-Image-Magick-6.3.2.9-10.3mdv2008.0.i586.rpm 
 4dd3532a6395bfbf5faa1e99207e016f  2008.0/SRPMS/imagemagick-6.3.2.9-10.3mdv2008.0.src.rpm

 Mandriva Linux 2008.0/X86_64:
 eac3f25719308817fae16f61b884fdd1  2008.0/x86_64/imagemagick-6.3.2.9-10.3mdv2008.0.x86_64.rpm
 64b28aeaff64cdf08995bdc48b8af531  2008.0/x86_64/imagemagick-desktop-6.3.2.9-10.3mdv2008.0.x86_64.rpm
 0fb0ab2f564fca7d63030c42e73757c3  2008.0/x86_64/imagemagick-doc-6.3.2.9-10.3mdv2008.0.x86_64.rpm
 51735dba9c7ffb6cbfb4b32fc4bcd02b  2008.0/x86_64/lib64magick10.7.0-6.3.2.9-10.3mdv2008.0.x86_64.rpm
 ae9e8d6f4dc0422a86314ed0ba07d05e  2008.0/x86_64/lib64magick10.7.0-devel-6.3.2.9-10.3mdv2008.0.x86_64.rpm
 96ca02b20d2340f94cd1a23a08d905af  2008.0/x86_64/perl-Image-Magick-6.3.2.9-10.3mdv2008.0.x86_64.rpm 
 4dd3532a6395bfbf5faa1e99207e016f  2008.0/SRPMS/imagemagick-6.3.2.9-10.3mdv2008.0.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories 

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team
  
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFLGmb3mqjQ0CJFipgRAjwqAJ9GvZyZxXOJOp3BqV3WFU/6pV4QvwCg6NgS
lzaRj3WCRvkJgfuD/dWac4I=4m8v
-----END PGP SIGNATURE-----



TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH