Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Linux :: Apps A-M :: tb10310.htm

libwpd: Multiple vulnerabilities



libwpd: Multiple vulnerabilities
libwpd: Multiple vulnerabilities




--U3s59FfKcByyGl+j
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200704-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/ 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: libwpd: Multiple vulnerabilities
      Date: April 06, 2007
      Bugs: #169675
        ID: 200704-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
libwpd is vulnerable to several heap overflows and an integer overflow.

Background
=========
libwpd is a library used to convert Wordperfect documents into other
formats.

Affected packages
================
    -------------------------------------------------------------------
     Package          /  Vulnerable  /                      Unaffected
    -------------------------------------------------------------------
  1  app-text/libwpd       < 0.8.9                            >= 0.8.9

Description
==========
libwpd contains heap-based overflows in two functions that convert
WordPerfect document tables. In addition, it contains an integer
overflow in a text-conversion function.

Impact
=====
An attacker could entice a user to convert a specially crafted
WordPerfect file, resulting in a crash or possibly the execution of
arbitrary code with the rights of the user running libwpd.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All libwpd users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-text/libwpd-0.8.9"

References
=========
  [ 1 ] CVE-2007-0002
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0002 
  [ 2 ] CVE-2007-1466
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1466 

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200704-07.xml 

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org. 

License
======
Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5 

--U3s59FfKcByyGl+j
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iQEVAwUBRhbVJjvRww8BFPxFAQJnOwf/YTM5G47n4Dl6Utm1XDW895HgL0SYryVg
wnGD2p+ncLdvodRtXhWXbxx7gDtsZo4xn7RO2XbmJ1ZMtq30qOpLa4kfcPi/WROw
XfXGEe0M+0fMMHlG7APvtCTdZ9aaQO2f7tC5GtoD+x/045vhNYw5PL3z1iYd5m0E
wbAxyb5IW76L9W+6C5wfqMWMXa/hF51QwS0DqprNxD3KmCFl3ISskceks1uJ5Lrf
Q+gpfYT/o4T1ZmFT98jpTUR9u49N7oppma3AxIqcC1S1CD00APDdMIbJgY01neV3
sNr1UKQCbCXfKBfDsE3IPT3Wk3GrO7iuLt6b2Sz2tF87GBkr/j88Eg==1S9n
-----END PGP SIGNATURE-----

--U3s59FfKcByyGl+j--


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH