Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: HP/UX :: ciach019.txt

HP-UX Software Install Programs Vulnerability





             __________________________________________________________

                       The U.S. Department of Energy
                    Computer Incident Advisory Capability
                           ___  __ __    _     ___
                          /       |     /_\   /
                          \___  __|__  /   \  \___
             __________________________________________________________

                             INFORMATION BULLETIN

                HP Software Installation Programs Vulnerability

December 20, 1996 00:00 GMT                                        Number H-19
______________________________________________________________________________
PROBLEM:       A vulnerability in the HP Software Distributor product, SD-UX,
               used to install, update, remove, and package HP-UX software and
               patches.
PLATFORM:      HP-ux 9.x and 10.x
DAMAGE:        May allow local users to gain root privileges.
SOLUTION:      Until patches are available, sites are recommended to take the
               action suggested in Section 3.
______________________________________________________________________________
VULNERABILITY  Exploit details involving this vulnerability have been made
ASSESSMENT:    publicly available.
______________________________________________________________________________

[ Start AUSCERT Advisory ]

===========================================================================
AA-96.04                        AUSCERT Advisory
               Vulnerability in HP Software Installation Programs
                                 11 October 1996

Last Revised:

----------------------------------------------------------------------------

AUSCERT has received information that there is a vulnerability in the
Hewlett Packard Software Distributor product, SD-UX, used to install,
update, remove and package HP-UX software and patches.  This software is
installed by default under HP-UX 10.x and may have been specifically
installed as additional software under HP-UX 9.x.  Any system with the
SD-UX package installed is vulnerable.

This vulnerability may allow local users to gain root privileges.

Exploit details involving this vulnerability have been made publicly
available.

Vendor patches are being developed, but until they are made available,
AUSCERT recommends that sites take the actions suggested in Section 3.

----------------------------------------------------------------------------

1.  Description

    The HP Software Distributor (SD-UX) is a package that provides a user
    interface which can be used to install, update, remove, and package HP-UX
    software and patches.

    The programs supplied with this package create files in an insecure
    manner.  As these programs execute with root privileges, it is possible
    to create or over-write arbitrary files on the system.  The default
    location of the programs supplied by the package is /usr/sbin.

    To determine if you have SD-UX installed on your system, check for
    the presence of the swinstall (and related) files using the
    following command:

        % ls -l /usr/sbin/sw*

    Individual sites are encouraged to check their systems for the SD-UX
    package, and if installed, take the actions recommended in Section 3.


2.  Impact

    Local users may be able to create or over-write arbitrary files on
    the system.  This can be leveraged to gain root privileges.


3.  Workarounds/Solution

    AUSCERT recommends that sites prevent possible exploitation of this
    vulnerability by taking the measures stated in Section 3.1 immediately.

    If software maintenance is required, AUSCERT advises that sites
    use one of the workarounds given in 3.2, preferably that described in
    Section 3.2.1.

    Vendor patches may also address this vulnerability in the
    future (Section 3.3).

3.1 Remove permissions

    Until official patches are available sites are encouraged to completely
    prevent the execution of all vulnerable SD-UX programs by any user
    (including root).

        # chmod 400 /usr/sbin/swinstall
        # chmod 400 /usr/sbin/swmodify

    Note that if only the setuid permissions are removed, it is still
    possible for users to gain the privileges of any user executing
    the SD-UX programs (including root).


3.2 Workarounds

    AUSCERT recommends that if software maintenance is required, sites
    implement one of the following workarounds until official vendor
    patches are made available.

    The workaround described in 3.2.1 is the preferred method of doing
    software maintenance.  If sites are unable to bring their machines
    into single user mode, the workaround given in Section 3.2.2 may be
    more applicable.

3.2.1  Run in single user mode

    If packages must be installed, the machine should be brought into
    single-user mode, execute permissions re-enabled on
    /usr/sbin/swinstall,

        # chmod 700 /usr/sbin/swinstall
        # chmod 700 /usr/sbin/swmodify

    and all symbolic links in /var/tmp and /tmp removed.  The following
    command can be used to remove the symbolic links:

        # find /tmp /var/tmp -type l -ok rm {} \;

    Once this has been completed, any software package maintenance may be
    safely performed.

    The execute permissions on the vulnerable programs must be removed
    before the machine is brought back into multi-user mode.

        # chmod 400 /usr/sbin/swinstall
        # chmod 400 /usr/sbin/swmodify

3.2.2 Change temporary file environment variable

    This workaround should only be used if the SD-UX programs must be used
    while the machine is in multi-user mode.

    The SD-UX programs use a number of temporary files.  The location of
    these files can be configured using the environment variable TMPDIR.
    It is possible to set the environment variable TMPDIR to a non-world
    writable directory.  Having the temporary files created in a non-world
    writable directory prevents the exploitation of the vulnerability
    described in this advisory.

    NOTE:  The environment variable must be set in each login
           session BEFORE any SD-UX programs are used.

    To use this method, the following steps must be taken:

    1) As root, create a non-world writable temporary directory for the
    temporary files used by the SD-UX programs.  The location of these
    temporary files can be configured with the TMPDIR environment variable.
    In this workaround, we have chosen to use the directory
    /var/tmp/SD_tmp.

        # mkdir /var/tmp/SD_tmp
        # chmod 700 /var/tmp/SD_tmp

    For this workaround to be effective, sites should ensure that the
    parent directory of $TMPDIR has the sticky bit set if the parent
    directory is world writable.  In this workaround, /var/tmp is the
    directory concerned.  The sticky bit on /var/tmp can be set with the
    command:

        # chmod 1777 /var/tmp


    In all sessions where software maintenance is performed:

    2) Change permissions on the vulnerable programs:

        # chmod 700 /usr/sbin/swinstall
        # chmod 700 /usr/sbin/swmodify

    3) Set the environment variable TMPDIR:

        (under csh)
        # setenv TMPDIR /var/tmp/SD_tmp

        (under sh)
        # TMPDIR=/var/tmp/SD_tmp; export TMPDIR

       and verify that the directory exists and is writable by root.

        # ls -ld $TMPDIR

     4) Perform any software package maintenance.

     5) Remove the execute permissions on the vulnerable programs:

        # chmod 400 /usr/sbin/swinstall
        # chmod 400 /usr/sbin/swmodify

     6) The environment variable TMPDIR is used by many other programs.
     You should either exit this interactive session, or reset the
     TMPDIR environment variables before continuing.

     NOTE:  Steps 2) through 6) must be repeated each time software
            maintenance is performed.

3.3 Install vendor patches

    Official vendor patches are currently being developed to address the
    vulnerability described in this advisory.  When vendor patches are
    made available, AUSCERT suggests that they be installed.


===========================================================================

[ End AUSCERT Advisory ]

_______________________________________________________________________________

CIAC wishes to acknowledge the contributions of AUSCERT for the
information contained in this bulletin.
_______________________________________________________________________________

CIAC, the Computer Incident Advisory Capability, is the computer
security incident response team for the U.S. Department of Energy
(DOE) and the emergency backup response team for the National
Institutes of Health (NIH). CIAC is located at the Lawrence Livermore
National Laboratory in Livermore, California. CIAC is also a founding
member of FIRST, the Forum of Incident Response and Security Teams, a
global organization established to foster cooperation and coordination
among computer security teams worldwide.

CIAC services are available to DOE, DOE contractors, and the NIH. CIAC
can be contacted at:
    Voice:    +1 510-422-8193
    FAX:      +1 510-423-8002
    STU-III:  +1 510-423-2604
    E-mail:   ciac@llnl.gov

For emergencies and off-hour assistance, DOE, DOE contractor sites,
and the NIH may contact CIAC 24-hours a day. During off hours (5PM -
8AM PST), call the CIAC voice number 510-422-8193 and leave a message,
or call 800-759-7243 (800-SKY-PAGE) to send a Sky Page. CIAC has two
Sky Page PIN numbers, the primary PIN number, 8550070, is for the CIAC
duty person, and the secondary PIN number, 8550074 is for the CIAC
Project Leader.

Previous CIAC notices, anti-virus software, and other information are
available from the CIAC Computer Security Archive.

   World Wide Web:      http://ciac.llnl.gov/
   Anonymous FTP:       ciac.llnl.gov (128.115.19.53)
   Modem access:        +1 (510) 423-4753 (28.8K baud)
                        +1 (510) 423-3331 (28.8K baud)

CIAC has several self-subscribing mailing lists for electronic
publications:
1. CIAC-BULLETIN for Advisories, highest priority - time critical
   information and Bulletins, important computer security information;
2. CIAC-NOTES for Notes, a collection of computer security articles;
3. SPI-ANNOUNCE for official news about Security Profile Inspector
   (SPI) software updates, new features, distribution and
   availability;
4. SPI-NOTES, for discussion of problems and solutions regarding the
   use of SPI products.

Our mailing lists are managed by a public domain software package
called ListProcessor, which ignores E-mail header subject lines. To
subscribe (add yourself) to one of our mailing lists, send the
following request as the E-mail message body, substituting
CIAC-BULLETIN, CIAC-NOTES, SPI-ANNOUNCE or SPI-NOTES for list-name and
valid information for LastName FirstName and PhoneNumber when sending

E-mail to       ciac-listproc@llnl.gov:
        subscribe list-name LastName, FirstName PhoneNumber
  e.g., subscribe ciac-notes OHara, Scarlett W. 404-555-1212 x36

You will receive an acknowledgment containing address, initial PIN,
and information on how to change either of them, cancel your
subscription, or get help.

PLEASE NOTE: Many users outside of the DOE, ESnet, and NIH computing
communities receive CIAC bulletins.  If you are not part of these
communities, please contact your agency's response team to report
incidents. Your agency's team will coordinate with CIAC. The Forum of
Incident Response and Security Teams (FIRST) is a world-wide
organization. A list of FIRST member organizations and their
constituencies can be obtained via WWW at http://www.first.org/.

This document was prepared as an account of work sponsored by an
agency of the United States Government. Neither the United States
Government nor the University of California nor any of their
employees, makes any warranty, express or implied, or assumes any
legal liability or responsibility for the accuracy, completeness, or
usefulness of any information, apparatus, product, or process
disclosed, or represents that its use would not infringe privately
owned rights. Reference herein to any specific commercial products,
process, or service by trade name, trademark, manufacturer, or
otherwise, does not necessarily constitute or imply its endorsement,
recommendation or favoring by the United States Government or the
University of California. The views and opinions of authors expressed
herein do not necessarily state or reflect those of the United States
Government or the University of California, and shall not be used for
advertising or product endorsement purposes.

LAST 10 CIAC BULLETINS ISSUED (Previous bulletins available from CIAC)

H-10: HP-UX Security Vulnerabilities (passwd, fpkg2swpkg, newgrp)
H-11: sendmail Group Permissions Vulnerability
H-12: IBM AIX(r) 'SYN Flood' and 'Ping o' Death' Vulnerabilities
H-13: IBM AIX(r) Security Vulnerabilities (gethostbyname, lquerypv)
H-14: SGI IRIX Vulnerabilities (systour, OutOfBox, cdplayer, datman)
H-15: Korn Shell (ksh) suid_exec Vulnerability
H-16: HP-UX Security Vulnerabilities (chfn, Remote Watch)
H-06a: Sun libc/libnsl vulnerabilities (Sun Bulletin #00137a)
H-17: cron/crontab Buffer Overrun Vulnerabilities
H-18: Denial-of-Service Attack via ping

RECENT CIAC NOTES ISSUED (Previous Notes available from CIAC)

Notes 07 - 3/29/95     A comprehensive review of SATAN

Notes 08 - 4/4/95      A Courtney update

Notes 09 - 4/24/95     More on the "Good Times" virus urban legend

Notes 10 - 6/16/95     PKZ300B Trojan, Logdaemon/FreeBSD, vulnerability
                       in S/Key, EBOLA Virus Hoax, and Caibua Virus

Notes 11 - 7/31/95     Virus Update, Hats Off to Administrators,
                       America On-Line Virus Scare, SPI 3.2.2 Released,
                       The Die_Hard Virus

Notes 12 - 9/12/95     Securely configuring Public Telnet Services, X
                       Windows, beta release of Merlin, Microsoft Word
                       Macro Viruses, Allegations of Inappropriate Data
                       Collection in Win95

Notes 96-01 - 3/18/96  Java and JavaScript Vulnerabilities, FIRST
                       Conference Announcement, Security and Web Search
                       Engines, Microsoft Word Macro Virus Update


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH