Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Linux :: Gentoo :: b06-4413.htm

Heimdal: Multiple local privilege escalation vulnerabilities



Heimdal: Multiple local privilege escalation vulnerabilities
Heimdal: Multiple local privilege escalation vulnerabilities



--nextPart4950536.OzGsFfed46
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200608-21
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/ 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Heimdal: Multiple local privilege escalation
            vulnerabilities
      Date: August 23, 2006
      Bugs: #143371
        ID: 200608-21

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Certain Heimdal components, ftpd and rcp, are vulnerable to a local
privilege escalation.

Background
=========
Heimdal is a free implementation of Kerberos 5.

Affected packages
================
    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  app-crypt/heimdal     < 0.7.2-r3                      >= 0.7.2-r3

Description
==========
The ftpd and rcp applications provided by Heimdal fail to check the
return value of calls to seteuid().

Impact
=====
A local attacker could exploit this vulnerability to execute arbitrary
code with elevated privileges.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All Heimdal users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-crypt/heimdal-0.7.2-r3"

References
=========
  [ 1 ] Official advisory
http://www.pdc.kth.se/heimdal/advisory/2006-08-08/ 
  [ 2 ] CVE-2006-3083
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3083 
  [ 3 ] CVE-2006-3084
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3084 

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200608-21.xml 

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org. 

License
======
Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5 

--nextPart4950536.OzGsFfed46
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQBE7KiTIS4GNEW6wBQRAjC9AJsH1c5ocduQhwkTjVqsyU2OB3ZccgCfRAen
jWXZV2WiMz54Cbl9TeWTHDU=c/zX
-----END PGP SIGNATURE-----

--nextPart4950536.OzGsFfed46--



TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH