Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Linux :: Gentoo :: b06-4057.htm

GnuPG: Integer overflow vulnerability



GnuPG: Integer overflow vulnerability
GnuPG: Integer overflow vulnerability



--nextPart1547949.5rN2e7rauR
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200608-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/ 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: GnuPG: Integer overflow vulnerability
      Date: August 05, 2006
      Bugs: #142248
        ID: 200608-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
GnuPG is vulnerable to an integer overflow that could lead to the
execution of arbitrary code.

Background
=========
The GNU Privacy Guard, GnuPG, is a free replacement for the PGP suite
of cryptographic software.

Affected packages
================
    -------------------------------------------------------------------
     Package          /  Vulnerable  /                      Unaffected
    -------------------------------------------------------------------
  1  app-crypt/gnupg       < 1.4.5                            >= 1.4.5

Description
==========
Evgeny Legerov discovered a vulnerability in GnuPG that when certain
packets are handled an integer overflow may occur.

Impact
=====
By sending a specially crafted email to a user running an affected
version of GnuPG, a remote attacker could possibly execute arbitrary
code with the permissions of the user running GnuPG.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All GnuPG users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-crypt/gnupg-1.4.5"

References
=========
  [ 1 ] CVE-2006-3746
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3746 

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200608-08.xml 

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org. 

License
======
Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5 

--nextPart1547949.5rN2e7rauR
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQBE1HyBzKC5hMHO6rkRAujjAKCOIEqmFN3qks+AUIIMaQaWQO28NgCfTchA
/PlzqzmbkLJrky2Th3hUqSY=YNXd
-----END PGP SIGNATURE-----

--nextPart1547949.5rN2e7rauR--


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH