Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Linux :: Gentoo :: b06-4045.htm

Courier MTA: Denial of Service vulnerability



Courier MTA: Denial of Service vulnerability
Courier MTA: Denial of Service vulnerability



--nextPart2295383.bJ2n0ULIfd
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200608-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/ 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Courier MTA: Denial of Service vulnerability
      Date: August 04, 2006
      Bugs: #135005
        ID: 200608-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Courier MTA has fixed a DoS issue related to usernames containing a "="
character.

Background
=========
Courier MTA is an integrated mail and groupware server based on open
protocols.

Affected packages
================
    -------------------------------------------------------------------
     Package           /  Vulnerable  /                     Unaffected
    -------------------------------------------------------------------
  1  mail-mta/courier      < 0.53.2                          >= 0.53.2

Description
==========
Courier MTA has fixed a security issue relating to usernames containing
the "=" character, causing high CPU utilization.

Impact
=====
An attacker could exploit this vulnerability by sending a specially
crafted email to a mail gateway running a vulnerable version of Courier
MTA.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All Courier MTA users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=mail-mta/courier-0.53.2"

References
=========
  [ 1 ] CVE-2006-2659
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2659 

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200608-06.xml 

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org. 

License
======
Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5 

--nextPart2295383.bJ2n0ULIfd
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQBE0tNvzKC5hMHO6rkRAtbIAJ0eoubnoCvVcmKGaKZDFRRu/i632gCdGfYy
6dJNiXOFO2i+1clhS5P/o18=ETW4
-----END PGP SIGNATURE-----

--nextPart2295383.bJ2n0ULIfd--


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH