Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Linux :: Gentoo :: b06-1775.htm

Cyrus-sasl: digest-md5 pre-authentication denial of service



Cyrus-SASL: DIGEST-MD5 Pre-Authentication Denial of Service
Cyrus-SASL: DIGEST-MD5 Pre-Authentication Denial of Service



--nextPart1318417.OlLVoHQmFT
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200604-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/ 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Cyrus-SASL: DIGEST-MD5 Pre-Authentication Denial of Service
      Date: April 21, 2006
      Bugs: #129523
        ID: 200604-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Cyrus-SASL contains a vulnerability in the DIGEST-MD5 process that
could lead to a Denial of Service.

Background
=========
Cyrus-SASL is an implementation of the Simple Authentication and
Security Layer.

Affected packages
================
    -------------------------------------------------------------------
     Package              /   Vulnerable   /                Unaffected
    -------------------------------------------------------------------
  1  dev-libs/cyrus-sasl      < 2.1.21-r2                 >= 2.1.21-r2

Description
==========
Cyrus-SASL contains an unspecified vulnerability in the DIGEST-MD5
process that could lead to a Denial of Service.

Impact
=====
An attacker could possibly exploit this vulnerability by sending
specially crafted data stream to the Cyrus-SASL server, resulting in a
Denial of Service even if the attacker is not able to authenticate.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All Cyrus-SASL users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-libs/cyrus-sasl-2.1.21-r2"

References
=========
  [ 1 ] CVE-2006-1721
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1721 

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200604-09.xml 

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org. 

License
======
Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0 

--nextPart1318417.OlLVoHQmFT
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQBESGJ6zKC5hMHO6rkRAlqYAJ0ZtByaIGdg09vZslY29rFwd+u21ACfSKn+
1nVtkRGcOcS4wQ6fj54k04g=N+sM
-----END PGP SIGNATURE-----

--nextPart1318417.OlLVoHQmFT--


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH