Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Linux :: Debian :: dsa-366.htm

eroaster - insecure temporary file



Debian Security Advisory

DSA-366-1 eroaster -- insecure temporary file

Date Reported:
05 Aug 2003
Affected Packages:
eroaster
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CAN-2003-0656.
More information:

eroaster, a frontend for burning CD-R media using cdrecord, does not take appropriate security precautions when creating a temporary file for use as a lockfile. This bug could potentially be exploited to overwrite arbitrary files with the privileges of the user running eroaster.

For the stable distribution (woody) this problem has been fixed in version 2.1.0.0.3-2woody1.

For the unstable distribution (sid) this problem has been fixed in version 2.2.0-0.5-1.

We recommend that you update your eroaster package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Source:
http://security.debian.org/pool/updates/main/e/eroaster/eroaster_2.1.0.0.3-2woody1.dsc
http://security.debian.org/pool/updates/main/e/eroaster/eroaster_2.1.0.0.3-2woody1.diff.gz
http://security.debian.org/pool/updates/main/e/eroaster/eroaster_2.1.0.0.3.orig.tar.gz
Architecture-independent component:
http://security.debian.org/pool/updates/main/e/eroaster/eroaster_2.1.0.0.3-2woody1_all.deb

MD5 checksums of the listed files are available in the original advisory.



TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH