Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Cisco :: b06-3068.htm

Cisco Secure ACS Cross Site Scripting Vulnerability.



Cisco Secure ACS Cross Site Scripting Vulnerability.
Cisco Secure ACS Cross Site Scripting Vulnerability.



FUJITSU SERVICES SECURITY ADVISORY=0D
DATE: 27-01-2006=0D
AUTHOR: THOMAS LIAM ROMANIS=0D
VENDOR: Cisco=0D
PRODUCT: Cisco Secure ACS=0D
VERSION(S) TESTED: Cisco Secure ACS version 2.3 UNIX hosted on Netscape FastTrack Server version 2.01c on Sun Solaris 8.0=0D
TITLE: Cisco Secure ACS LogonProxy.cgi Cross Site Scripting vulnerability.=0D
=0D
Summary:=0D
Cisco Secure ACS LoginProxy.cgi has been found to be vulnerable to Cross Site Scripting attacks via both GET and POST requests due to a failure to properly filter undesirable user input. Successful exploitation could result in a loss of privacy of sensitive data, such as usernames and passwords.=0D
=0D
Detail:=0D
Exploitation of this type of attack relies on the attacker=92s ability to inject code (in this case java script) into the HTML that is delivered to the user=92s Internet Browser. In this case it is possible to craft POST and GET requests to LogonProxy.CGI that result in detailed errors being presented in which the requested URL (or Query) is displayed. Thus, it is possible to inject java script into the error message which could be utilised to execute a Cross Site Scripting attack. =0D
In this case the attack could not be used to steal session information (as it is commonly used) but it could be used to redirect the user to another host. A possible scenario would be that the user is redirected to a host owned by the attacker which hosts a copy of the Cisco Secure ACS front end. This would then be used to proxy logon requests back to the bone fide server whilst harvesting administrative user credentials.=0D
=0D
Exploitation: =0D
The following test scripts could be used to ascertain whether the system under test is vulnerable:=0D
=0D
1. POST Request.=0D
POST http://10.17.12.184:80/CScgi/LogonProxy.cgi HTTP/1.0=0D 
Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, */*=0D
Referer: http://10.17.12.184/cs/index.html=0D 
Accept-Language: en-gb=0D
Content-Type: application/x-www-form-urlencoded=0D
Proxy-Connection: Keep-Alive=0D
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)=0D
Host: 10.17.12.184=0D
Content-Length: 33=0D
Pragma: no-cache=0D
Server=0.0.0.0&error==0D
=0D
2. GET Requests.=0D
=0D">http://10.17.12.184/CScgi/LogonProxy.cgi?Server=0.0.0.0&error==0D 
=0D
http://10.17.12.184/CScgi/LogonProxy.cgi?Server=10.17.12.184/Logon?null&SSL==0D 
=0D
http://10.17.12.184/CScgi/LogonProxy.cgi?Ok==0D 
=0D
Recommendations: (Until patch information is available).=0D
These recommendations are based on Cisco Secure ACS being used on an internal network rather than an internet facing system.=0D
=95	If possible reconfigure the system so that detailed error messages are not displayed in the user=92s internet browser.=0D
=95	Network Architecture Design should ensure that only the IP addresses of hosts used by bone fide Cisco Secure ACS users/Administrators can connect to these services.=0D
=95	Consider dissemination of the attack string along side of controls in place on systems such as e-mail (spoofing and HTML e-mail), Vulnerable web services (publication/uploading of malicious code), exploitable applications (eg: guestbooks) and code published in MS Office document types.=0D
=95	Consider whether current controls on desktops and servers are adequate to prevent users from installing and controlling their own network services. =0D
Recommendations supplied to the Vendor:=0D
Logonproxy.cgi needs to have addition code added to filter out undesirable requests. The characters which should be filtered in all forms (i.e. ASCII and UNICODE etc) to avoid Cross Site Scripting attacks are: <,>,>,<,(,),=94,/,=,:,;,=0D
=0D
Vendor Recommendations:=0D
A new version of fastadmin.zip will be made available by Cisco at the following location:=0D
http://www.cisco.com/warp/public/707/cisco-sr-20060615-acs.shtml=0D 
=0D
Once you have downloaded this follow these instructions:=0D
=0D
Steps to install the patch:=0D
============================0D
=0D
1) Stop the Ciscosecure process using $BASEDIR/utils/kcs=0D
2) Create a backup of the existing file $BASEDIR/FastAdmin/fastadmin.zip=0D
3) Copy the patch(fastadmin.zip) to the location $BASEDIR/FastAdmin=0D
4) Start the CiscoSecure process using $BASEDIR/utils/scs=0D
=0D
Final Comments:=0D
Fujitsu Services would like to thank Paul Oxman and Cisco for their cooperation and professionalism.=0D


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH