Visit our newest sister site!
Hundreds of free aircraft flight manuals
Civilian • Historical • Military • Declassified • FREE!


TUCoPS :: Web :: Blogs :: b06-2862.htm

WordPress: Arbitrary command execution



WordPress: Arbitrary command execution
WordPress: Arbitrary command execution



--nextPart1313099.RR8WgqA80r
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200606-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/ 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: WordPress: Arbitrary command execution
      Date: June 09, 2006
      Bugs: #134397
        ID: 200606-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
WordPress fails to sufficiently check the format of cached username
data.

Background
=========
WordPress is a PHP and MySQL based content management and publishing
system.

Affected packages
================
    -------------------------------------------------------------------
     Package             /  Vulnerable  /                   Unaffected
    -------------------------------------------------------------------
  1  www-apps/wordpress       < 2.0.3                         >= 2.0.3

Description
==========
rgod discovered that WordPress insufficiently checks the format of
cached username data.

Impact
=====
An attacker could exploit this vulnerability to execute arbitrary
commands by sending a specially crafted username. As of Wordpress 2.0.2
the user data cache is disabled as the default.

Workaround
=========
There are no known workarounds at this time.

Resolution
=========
All WordPress users should upgrade to the latest available version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/wordpress-2.0.3"

References
=========
  [ 1 ] CVE-2006-2667
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2667 
  [ 2 ] CVE-2006-2702
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2702 

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200606-08.xml 

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
http://bugs.gentoo.org. 

License
======
Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5 

--nextPart1313099.RR8WgqA80r
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQBEiePnzKC5hMHO6rkRAqFBAJ9n2LM68VPaVqes3YK+RSooAepl3QCgjux9
U1XYVxlXJSCjtnjnO9/Tt4Y=+m+b
-----END PGP SIGNATURE-----

--nextPart1313099.RR8WgqA80r--


TUCoPS is optimized to look best in Firefox® on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH