AOH :: HP Unsorted N :: B1A-1196.HTM

Newt: User-assistnano: Multiple vulned execution of arbitrary code



Newt: User-assisted execution of arbitrary code
Newt: User-assisted execution of arbitrary code



--Sig_/cJdl2yj6snonQu8/L3nLoKV
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201006-14
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/ 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Newt: User-assisted execution of arbitrary code
      Date: June 02, 2010
      Bugs: #285854
        ID: 201006-14

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
A heap-based buffer overflow in the Newt library might allow remote,
user-assisted attackers to execute arbitrary code.

Background
=========
Newt is a library for displaying text mode user interfaces.

Affected packages
================
    -------------------------------------------------------------------
     Package        /   Vulnerable   /                      Unaffected
    -------------------------------------------------------------------
  1  dev-libs/newt     < 0.52.10-r1                      >= 0.52.10-r1

Description
==========
Miroslav Lichvar reported that Newt is prone to a heap-based buffer
overflow in textbox.c.

Impact
=====
A remote attacker could entice a user to enter a specially crafted
string into a text dialog box rendered by Newt, possibly resulting in
the remote execution of arbitrary code with the privileges of the user
running the application, or a Denial of Service condition.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All Newt users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-libs/newt-0.52.10-r1"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since October 26, 2009. It is likely that your system is
already no longer affected by this issue.

References
=========
  [ 1 ] CVE-2009-2905
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2905 

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201006-14.xml 

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at 
https://bugs.gentoo.org.

License
======
Copyright 2010 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5 

--Sig_/cJdl2yj6snonQu8/L3nLoKV
Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)

iEYEARECAAYFAkwGyqkACgkQk+oqhfPAZGmRuwCfdKAcrh633PadfVHZNg04rKDJ
GJQAniQIIYUvxUjsep27YenEJM5euYD1
=VuYe
-----END PGP SIGNATURE-----

--Sig_/cJdl2yj6snonQu8/L3nLoKV--

The entire AOH site is optimized to look best in Firefox® 3 on a widescreen monitor (1440x900 or better).
Site design & layout copyright © 1986-2014 AOH
We do not send spam. If you have received spam bearing an artofhacking.com email address, please forward it with full headers to abuse@artofhacking.com.